Version History of DivX 5.x (Windows)

Home » DivX » DivX 5.x (Windows) Version History

DivX 5.x Version History

DivX DivX Pro

This is the version history of DivX 5.x for Windows operating systems.

We also maintain a list of known issues in the current version.

Version 5.1 released 2003-09-02

New:

  • Added a new high-quality psychovisual mode that includes the following features:
    • Texture cortex masking and rate distortion algorithm
    • Hybrid mode (with texture cortex masking)
    • Speed optimization
    • Chroma operation (this option is not enabled by default for performance reasons; to enable it, create an empty file in C:\ called "DivxPvShapingChroma.txt" for "fast" mode and "DivxPvSimpleChroma.txt" for slow mode; testing shows only 1-2% gains in JND tests)
  • The decoder has been rearchitected and is now 10 to 30% faster on all CPU platforms.
  • The decoder now supports automatic post-processing during video playback.
  • Added new features to the rate control modes of the encoder, including:
    • A complexity vector log file
    • An API that allows real-time control of rate control
    • An API that allows forced I-frame insertion

Improved:

  • Redesigned encoder GUI. The new GUI is more accessible and simplifies overall usage.
  • DivX 3 compatibility. (There were no problems detected on any of the more than 60 hours of test content.)
  • Performance of Nth Pass strategy planning performance.

Fixed:

  • A bug that caused the quantizer to overshoot the bitrate following a transition to a complex scene.
  • A bug that limited the interframe change in quantizer to the ideal quantizer or plus or minus 2.
  • A bug in RGB32 to YUV conversion on Pentium 4 machines.
  • A minor bug that affected multiple CPU configuration.
  • A bug with the rate control video buffer verifier (VBV) that would enforce a "3 sec" max bitrate.
  • Several bugs that affected Nth Pass encoding strategy planning.
  • A bug that caused a different number of frames to be reported between different passes in VirtualDub.
  • A bug that caused motion vector (MV) reuse to be non-functional.
  • A bug that caused problems when MV reuse and psychovisual mode were used together.
  • Several bugs with the installer.
  • A bug that caused a crash when setting crop/resize values.

Back to Top

Version 5.0.5 released 2003-04-24

Fixed:

  • A bug that would cause the codec to encode every frame as an I-Frame when used with certain applications (e.g., AVIUtil, DVD2AVI, and some video capture applications).

Back to Top

Version 5.0.4 released 2003-04-17

Changed:

  • The new RC doesn't use Q=1 frames anymore
  • No stuffing used, bitrate can be too low in some extreme cases.
  • Strategy planning for rate control is much faster now
  • Better tracking of the planned RC strategy creating more consistent quality.

Fixed:

  • K6-2 CPU related crash resolved.
  • Not able to change Bitrate Modulation through CLI field.
  • During 1 pass quality-based, Quantizer can now be set to 1 with CLI
  • Multiple error windows no longer open upon entering wrong bitrate modulation option.
  • 'Max Keyframe Interval' no longer accepts negative values
  • Multiple error windows no longer open upon entering wrong CLI option.
  • In the Quick Config CLI field, 'Enable Resize' was taking invalid options
  • Fixed CLI inconsistencies when "Restore codec's default" is pressed.
  • Max bitrate and encoding bit rate(average) was displayed same.
  • Fixed hitting tab in the CLI field to enable 'Use Bidirectional Encoding'
  • Fixed: remove -w in the Quick Config CLI field, 'Update Log file' option is not getting deselected.
  • When 'Psychovisual Enhancements' value is set to 4, in the Quick Config CLI field, mismatch in slider and label options.
  • 1 Pass and Nth Pass™ undersized file should be fixed
  • Certain dark sequences would produce a long period of frames using a Quantizer of 31.
  • Psychovisual Enhancement field sometimes displayed "Custom" instead of Light when unselected
  • "Do not prompt with errors and warnings" would select itself when random characters were entered in the CLI after the "-key" option
  • When "-d 3" option was entered in the CLI field, "Source interlace" became blank.
  • Max bitrate would not update at times.
  • DirectShow decoder postprocessing slider became disabled with ATI radeon 9700 Graphics card
  • DirectShow decoder would "fast forward" when seeking backwards. This could cause synch issues when re-encoding DivX Files using the DivX Decoder Filter.
  • Various cosmetic fixes in the Encoder GUI
    • Do not prompt Error unchecked as default fixed.
    • Light Psychovisual enabled itself automatically when exiting the CLI field.
    • Max bitrate reset itself to x10 the average when going in the "profile" tab
  • MPEG-4 "type Indicator" correctly set according to selected encoding parameters
  • No more green first frame at very high bitrates.
  • Decoder updates the display to the appropriate frame when seeking
  • Decoder remembers the postprocessing settings
  • Fixed some memory leaks related to Psychovisual and Nth Pass™ mode
  • Nth Pass™ RC is tweaked to minimize the usage of high quantizer
  • Nth Pass™ doesn't create an empty frames at the beginning of the clip
  • Brightness/Saturation sliders now working correctly.

Back to Top

Version 5.0.3 released 2003-01-24

New:

  • Support for interlaced video in the decoder. Preserving the interlaced fields of interlaced video may sometimes result in better video quality during playback.
  • New de-ringing post-processing algorithm. The new algorithm improves the perceived video quality during playback. It is activated when the post-processing level is set to Level 6.
  • Video Buffer Verifier (VBV) model (one and two pass encoding). The VBV ensures that the maximum peak bit rate never exceeds either the user's inputted "maximum peak" bit rate value or/and ensures that the encoded stream never violates the buffer of an MPEG-4 compliant decoder. This helps to prevent decoding failure in both hardware and software where memory may be limited yet compliant to the MPEG-4 standard as defined in ISO/IEC 14496-2:2001(E). In order for DivX video to be successfully delivered over a restricted channel in real time to a decoder, the encoder's rate control must ensure that the decoder's buffer is not violated. When this is done properly, then overflow and underflow will never occur and the encoder is said to be "VBV compliant." It makes no difference whether the video is encoded in 1-pass or many, in real-time or offline. It is the encoder's rate control that must ensure compliance. There are three main requirements of a VBV-compliant rate control algorithm, in order of importance:
    1. VBV compliance. When VBV parameters are specified (size, initial occupancy, channel characteristics) the rate control should avoid producing video that is in danger of violating the decoder's buffer. Bitstream stuffing may be used in extreme cases to prevent overflow in true CBR systems. Underflow must be prevented by increasing frame quantiser or by dropping frames.
    2. Target bitrate. We aim to meet the user's requirements as accurately as possible here. This is directly related to filesize.
    3. Good-looking video. Rate control should aim to produce the subjectively best quality video given other constraints. Consistency is important here as changes in quality are very noticeable and video is often judged by the worse quality segment in the whole sequence.
  • Nth Pass™ encoding. Another new addition to the rate control arsenal, Nth Pass™ encoding takes advantage of information available from previous analysis (or analyses) of the video sequence. Nth Pass encoding uses information garnered from previous passes through the video sequence, which can improve quality with each pass. There are four main steps to Nth Pass encoding:
    1. Analysis (the first pass)
    2. Map generation (where the results of analyses are processed)
    3. Strategy generation (strategist examines map of the video sequence and creates a strategy that will best achieve the three VBV RC requirements)
    4. In-loop nth pass rate control (uses information from the map and strategy to effect rate control that best fulfills the three requirements)
  • Support for DivX Certified Profiles. With the new DivX Certification program, DivXNetworks is enabling third parties to create "DivX Certified" products that are rigorously tested and fully compatible with the entire suite of DivX® video technologies. There are four levels of official DivX Certified video products: Handheld Video Devices, Portable Video Devices, Home Theater Video Devices and High Definition Video Devices. These levels quickly and clearly communicate what type and size of DivX video are supported on the certified device. Now, when you encode video, you have the option to force your video to comply with one of the DivX Certified Profiles to ensure that your video will play back properly on certified products.
  • DivX Decoder verification logo. There is a new semi-transparent DivX Logo that will appear by default for a few seconds any time you use the DivX decoder to watch a DivX video. This instantly lets you know you're watching a true DivX® video. You can turn the display of the logo on or off in the codec properties dialog.
  • New internal application programming interface (API). The internal API of the codec was changed to better accommodate integration with third party partners. This only affects you if you are a DivX licensee and are working directly with the DivX object code. The external API (e.g., DirectShow, etc.) remains unchanged.

Improved:

  • The motion estimation algorithm is better optimized for High Definition resolutions (up to 1080p, or 1920 x 1080 pixel resolution
  • The pre-processing performance is now improved with with the IYUY 4:2:0 color space

Changed:

  • Removed MP4creator and the MPEG-4 file output option due to some compliance issues. This will return in our next release once these issues are resolved.
  • Removed the Intelligent IVTC functionality due to persistent problems caused by lack of variable frame rate file format support. This technology will be back soon in a new form...
  • Changed the block skipping threshold for high quantizers, which improves visual quality when high quantizers are used.

Fixed:

  • Fixed a bunch of little cosmetic bugs in the DirectShow decoder properties page.
  • Fixed a bug where the last P frame before an I frame was not displayed when Smooth Playback was selected.
  • Fixed a practically unnoticeable YUV->RGB16 color conversion rounding bug.
  • Fixed a bug that was the cause of some of VirtualDub's "Cannot Start Video Compression" errors.
  • Fixed a few issues with DivX 3.11 compatibility.
  • Modified the decoder to deal with a bug in the old OpenDivX encoder that set the scalability bit incorrectly in certain cases. The DivX decoder can now detect this problem and play the content properly.
  • Fixed a problem where some rounding operations were not done toward zero, as is required by section 7.4 of the spec. This fixed an intra case in MPEG-2 inverse quantization.
  • Fixed a bug where some frames would be corrupted by an out-of-range error.
  • Fixed several rounding issues related to MMX/SSE/SSE2 optimizations.
  • Fixed an MMX bug in RGB32 color conversion.

Back to Top

Version 5.0.2 released 2002-05-16

New:

Added several new options to the codec properties dialog that allow users to tweak settings for smoother playback and improved support for some video cards.

  • Added a "Smooth Playback" option. Turning this off will allow B-frame encoded content to playback with lower CPU usage. However, enabling this option will introduce a 1 frame delay in the decoder (because of buffering), which may cause the last frame of the video to not be displayed.
  • Added a "YUV Extended" mode option. When selected, the codec will attempt to use YV12 mode to decode the video. This is the fastest way to decode DivX content, but the drawback is that brightness/contrast/saturation controls cannot be used in this mode and are disabled.
  • Added an "Overlay Extended" mode. Selecting this will cause the filter to try to display video using the hardware overlay instead of the software overlay. The hardware overlay is much faster, but may not be supported on some video cards. When this mode is enabled, DirectShow-based player applications will be unable to open more than one window at a time.
  • Added a "Double Buffering" option. Enabling this will force the video card to allocate a second buffer for the video playback. This will increase the smoothness of the video playback, but may not be supported on low-end video cards with less than 8 MB of RAM.
  • Added a "Film Effect" option. This is a warming filter that when enabled will add film noise to the decoded picture. This may increase the perceived visual quality of the picture, especially if you are used to watching film. It's a personal preference, however, so use it if you want.
  • Added a hidden "Force Color Mode" control. You can manually set the registry key "HKEY_CURRENT_USER\Software\DivXNetworks\Force Color Mode" in the Windows Registry and assign it a number from 1 to 7. This will force the video card to use a particular color mode, depending upon the value. This is only necessary in rare circumstances to solve video card problems. Supported color modes:
    • 1: YV12
    • 2: YUY2
    • 3: YUYV
    • 4: RGB32
    • 5: RGB24
    • 6: RGB555
    • 7: RGB565

Improved:

  • The default psychovisual modeling settings are tweaked slightly. This should decrease blockiness in black regions and flat areas in the video content.
  • Optimized the decoder so that it more consistently plays back video, particularly on lower-end CPUs. (A P-III 466 MHz machine can play real-time, 640x480 video with B-frames and GMC at 80% CPU load.)

Fixed:

  • Fixed a lot of memory leaks in the encoder. This should prevent the codec from slowing down gradually during a long encode.
  • Version 5.0.1 encoded 7% slower than 5.0. DOH! Not sure how that happened. This has been fixed and version 5.0.2 is as fast as version 5.0.
  • Fixed a problem where the trace_b.txt log file would be written out during encodes which would take up significant disk space. The log file is no longer written.
  • Fixed a problem where the MP4 Creator would not work on files that included B-frames. The MP4 Creator should now work with all DivX 5.x files.
  • Fixed a bug where the right macroblock would not be displayed with the custom brightness/contrast settings. This would cause a dark or light "band" of video on the right side of the screen.
  • Fixed a bug that would cause playback problems when the seek bar was moved back and forth quickly. This same bug some cause bad frames to be displayed at the beginning of some content when playing back video in Windows Media Player. This should no longer happen.
  • Fixed a bug where the "Decoder Configuration" application would crash when run on Windows 98. The application should now run properly. (Yes, we know we said we fixed this in 5.0.1, but we really fixed it this time.)

Back to Top

Version 5.0.1 released 2002-04-09

Improved:

  • Psychovisual modeling enhancements now reallocate saved bits in an improved manner, meaning the psychovisual modeling mode will produce better visual quality.
  • Improved the workaround for a DirectShow bug that causes the requested bitrate to not be respected by the codec during one-pass encoding. This affects applications (such as video capture applications) that use the DivX DirectShow interface to access the codec. This problem is due to a bug in DirectShow, not in DivX itself, but we have a workaround that should solve the problem.

Fixed:

  • Fixed a bug where the divx.dll library would not decode DivX 3.x content properly. This affected applications like VirtualDub that use the VfW interface to use DivX. The problems this caused, such as blank frames, are now fixed.
  • Fixed a bug where basic deinterlace functionality would cause the codec to crash on Pentium 4 processors.
  • Fixed a problem where using data paritioning and psychovisual modeling together would produce severe visual artifacts. These settings can now be used together.
  • Fixed an issue where encoding content with resolutions not divisible by 16 would cause purple and pink artifacts to appear in the encoded content. These artifacts no longer appear. You can now encode content that has resolutions divisible by 4 or 8, however we still strongly recommend encoding only content with resolutions divisible by 16, as the 4 and 8 dimensions will not encode as efficiently. (There remains a known issue about resolutions divisible by 2.)
  • Fixed a bug where the DirectShow filter would not use the overlay properly with Matrox Millennium video cards on Windows 2000. It now works properly.

Back to Top

Version 5.0 released 2002-03-04

Initial public version of DivX 5.0.

Features:

  • Compatibility with all versions of DivX video content. DivX 5.0 can play every version of DivX video ever created, from prior to 3.11 alpha to the brand new DivX Pro 5.0.
  • AMD optimizations. Version 5.0 is fully optimized for AMD Athlon and Athlon XP processors, meaning AMD owners can see performance speedups of up to 20%.
  • Improved encoding and decoding performance. We've also optimized the encoding and decoding algorithms across the board, improving performance for all users. Double Real Time encoding is possible on modern hardware, and Triple Real Time encoding is possible on two processor systems. Version 5.0 can even decode 1080p high-definition video content in real time.
  • Faster two-pass encoding. We've tweaked the way two-pass encoding works. The second pass now uses more data from the first pass, making the second pass up to 30% faster than DivX 4.12.
  • Smaller file sizes. All the new encoding features of DivX 5.0 mean you can expect equivalent visual quality at about 15-20% smaller file sizes.
  • MPEG-4 compatibility. DivX 5.0 can decode MPEG-4 Simple Profile, MPEG-4 Advanced Simple Profile, and H.263 video (all levels). It is also able to encode fully MPEG-4 Simple Profile compliant video (ISO/IEC 14496-2).
  • DivX® MPEG-4 file format. This version of DivX introduces a brand new MPEG-4 based file format that replaces the venerable AVI. No more audio/video synchronization problems, and no more 2 GB file limit.
  • Advanced support for existing encoding applications. All the new features of DivX 5.0 work in today's existing content creation and encoding applications. You don't even need new versions of the applications! So continue using Adobe Premiere, VirtualDub, or whatever is your application of choice.
  • Reusable encoding profiles. Version 5.0 allows you to save profiles of encoding settings and reuse them over and over. You can also trade encoding profiles with other users.
  • Quick configuration CLI. DivX 5.0 includes a command line interface for advanced users that gives an extra level of control over encoding parameters.
  • Patent-pending rate control algorithm. This new version of DivX introduces a new and improved rate control algorithm. It just makes things look better, okay? If you want to know more, read the help file or what's new sections.
  • Improved encoding algorithms. We've introduced special encoding algorithms that are specifically tuned to pans, fades, zooms, explosions, etc. With DivX 5.0, you should see visual quality improvements on these types of special scenes.
  • Psychovisual modeling. The coolest new feature of DivX 5.0 is psychovisual modeling, and advanced technique that takes into account knowledge about how the Human Visual System (HVS) works to compress moving video images into much smaller sizes without a loss of video quality. Expect up to 20% smaller file sizes from using this feature.
  • Universal architecture. Create once, play anywhere. The universal VfW/ACM/QT architecture of DivX makes it possible to playback exactly the same file on a variety of different operating systems and applications.
  • Mac OS Support. For the first time, a publicly available codec on Mac OS can decode MPEG-4 Simple Profile and MPEG-4 Advanced Simple Profile video.
  • Scalable. DivX video has been test on and can work on a wide range of video bitrates, from 28 Kbps to 9 Mbps, depending upon your encoding needs.
  • New DivX Player 2.0 Alpha. A brand new DivX Player application, complete with MPEG-4 file format support and a spiffy new skin system, is ready for your perusal.

For a list of all the new features released in DivX 5.0, check out What's New in DivX 5.0.

Back to Top
Dr. DivX is here
New DivX Pro 5.0.5 for Mac

More DivX

  • Windows Windows
  • Mac OS Mac OS
  • Linux Linux
  • Adult
  • Alternative
  • Anime
  • Cult
  • Educational
  • Grab Bag
  • Hip Hop
  • Independent
  • Trash/Horror
  • Videomaking
Download DivX 5.0.3

Questions?

Have a Question?
Search our FAQ or
visit our Help Desk.

Home | DivX | Movies | Software | Hardware | Skins | Forums | Support
About DivX | Contact Us | Advertising | Jobs | Corporate Information | DivX Labs

Copyright © 2000-2003 All rights reserved.
DivX® is a registered trademark of DivXNetworks, Inc.